【cocos2dx】OpenSSLのセキュリティ問題への対処方法

【cocos2dx】OpenSSLのセキュリティ問題への対処方法
   

前日に「Security Alert: You are using a highly vulnerable version of OpenSSL」というタイトルのメールが届きました。
Android側で、アプリのセキュリティの脆弱性があるので対処をしてほしいという内容です。

結果的に、原因は「cocos2dxのlibcurl.a」での問題でした。



対処方法

まずは、上記のcocos2dxのページから新しい[libcurl.a]をダウンロードします。
Downloads

これをcoocs2dxのプロジェクトに置き換えて上げれば良いのです。
場所はフォルダから見て、おそらくこの3箇所です。
  • ../cocos2dx/platform/third_party/android/prebuilt/libcurl/libs/x86/libcurl.a
  • ../cocos2dx/platform/third_party/android/prebuilt/libcurl/libs/armeabi/libcurl.a
  • ../cocos2dx/platform/third_party/android/prebuilt/libcurl/libs/armeabi-v7a/libcurl.a

最後に

現在はAndroidのアプリを全て修正をしました。
これで、何も無ければ大丈夫かと思います。

ただ、他のSDKなどが原因ということもありますので、プロジェクトの環境にあった対応をしてみてください。

Related Posts Plugin for WordPress, Blogger...