[cocos2d]  MacOSを「OS X Mountain Lion」にアップグレードしたときに出てくる「xcode」のエラーを修正する

  • |
[cocos2d]  MacOSを「OS X Mountain Lion」にアップグレードしたときに出てくる「xcode」のエラーを修正する
   

本日、Appleが正式リリースをした「OS X Mountain Lion」にアップグレードした際に、色々しなくては行けないことが出てきたので、その修正点を簡単に書いていきたいと思います。

修正点1 xcodeをアップデートする 

まず最初にすべきことは、Xcodeを「OS X Mountain Lion」に対応させること。
これをしないとxcode自体立ち上がりません。

方法は、Macのアプリである「APP Store」を立ち上げます。
2012 7 28 ffrr



アップデートの所に赤く①と表示がでているので、ここから行います。

2012 7 28 44



修正点2 エラー「 Format specifies type ‘unsigned int’ but the argument has type ”」

xcodeを立ち上げて以前のように実行すると、動くことは動くのですが、何故か結構多くのエラーが出てきます。
スクリーンショット 2012 07 28 19 04 56


よくみると、どれも同じエラーです。
スクリーンショット 2012 07 28 19 05 11

色々調べてみると、この2つのサイトに解決策が載っていました。

英語なんですが、xcodeをver4.4に変えたときにエラーがでるので以下の点を個別に修正してくださいと言う内容です。

これに関しては「cocos2dver2.0」以降では修正されているみたいです。

例えばCCActionクラスのエラーでは以下のように直さないといけません。
//%08X
-  return [NSString stringWithFormat:@"<%@ = %08X | Tag = %i>", [self class], self, tag_];

↓↓↓↓↓↓↓
//%p 
+  return [NSString stringWithFormat:@"<%@ = %p | Tag = %i>", [self class], self, tag_];


最後に

とてもめんどくさそうです。
本当ならcocos2dのバージョンを上げたいのですが、結構作りこんだのでナニかエラーが出ると怖いのでしてません。

とりあえずその他何か問題が出てくれば個別にブログにも書いていきたいです。

Related Posts Plugin for WordPress, Blogger...
photo by: juzsan